Anforderungen

Webserver

Da die Oberfläche von phpMyAdmin komplett in Ihrem Browser läuft, brauchen Sie einen Webserver (wie zum Beispiel Apache, nginx, IIS), um die Dateien von phpMyAdmin dort zu installieren.

PHP

  • Sie benötigen PHP 7.1.0 oder neuer, mit session Unterstützung, die Standard PHP Library (SPL) Erweiterung, Hash, ctype und JSON Unterstützung.
  • Aus Performance-Gründen wird die Erweiterung mbstring (siehe mbstring) dringend empfohlen.
  • Um ZIP-Dateien hochzuladen brauchen Sie die PHP Erweiterung zip.
  • Sie brauchen GD2 Unterstützung in PHP, um eingebettete Miniaturbilder von JPEGs („image/jpeg: inline“) mit ihrem originalen Seitenverhältnis anzuzeigen.
  • Beim Verwenden von Cookie-Authentifizierung (Standard) wird die openssl-Erweiterung ausdrücklich empfohlen.
  • Für Unterstützung von Upload-Fortschrittsbalken siehe 2.9 Einen Fortschrittsbalken für den Upload sehen.
  • Um XML- und Open Document Spreadsheet-Importe zu unterstützen, benötigen Sie die libxml-Erweiterung.
  • Für die Nutzung von reCAPTCHA auf der Login-Seite benötigen Sie die openssl-Erweiterung.
  • Um das Anzeigen der letzten phpMyAdmin Version muss allow_url_open in der :file: php.ini aktiviert oder die curl <https://secure.php.net/curl> - Erweiterung installiert sein.

Datenbank

phpMyAdmin unterstützt MySQL-kompatible Datenbanken.

  • MySQL 5.5 oder neuer
  • MariaDB 5.5 oder neuer

Webbrowser

Um auf phpMyAdmin zuzugreifen, brauchen Sie einen Webbrowser, in dem Cookies und Javascript aktiviert sind.

Sie brauchen einen Browser, welcher jQuery 2.0 unterstützt. Weitere Informationen finden SIe unter <https://jquery.com/browser-support/>.