Nõuded

Veebiserver

Kuna phpMyAdmin liides põhineb täielikut veebibrauseril, vajad sa veebiserverit (näiteks Apache, nginx või IIS), kuhu paigaldada phpMyAdmin’i failid.

PHP

  • Sa vajad PHP versiooni 7.2.5 või uuemat, millel on sessiooni tugi, Standard PHP Library (SPL) laiendust ning hash, ctype ja JSON’i tuge.
  • The mbstring extension (see mbstring) is strongly recommended for performance reasons.
  • ZIP failide üles laadimiseks peab olema toetatud „zip“ laiend.
  • Tekstisiseste JPEG pisipiltide („image/jpeg: inline“), mille külgede suhe vastab originaalile, kuvamiseks peab PHP toetama teeki GD2.
  • Kui kasutada küpsistel põhinevat autentimist (vaikimisi autentimine), siis on tungivalt soovitatav kasutada laiendust openssl.
  • Üleslaadimise edenemisriba toest vaata lähemalt 2.9 Seeing an upload progress bar.
  • Importimiseks XML ja ODS (avatud dokumendi tabelarvutus) vormingutest vajad PHP laiendit libxml.
  • Sisselogimisel reCAPTCHA kasutamiseks on sul vaja openssl laiendust.
  • phpMyAdmini uusima versiooni kuvamiseks pead lubama allow_url_open funktsiooni failis php.ini või paigaldama laienduse curl.

Andmebaas

phMyAdmin toetab MySQL’ga ühilduvaid andmebaase.

  • MySQL 5.5 või uuem
  • MariaDB 5.5 või uuem

Veebilehitseja

phpMyAdmin’i kasutamiseks vajad veebilehitsejat, millel on küpsised ja JavaScript lubatud.

Vajad lehitsejat, mida Bootstrap 4.5 toetab, vaata <https://getbootstrap.com/docs/4.5/getting-started/browsers-devices/>.

Muudetud versioonis 5.2.0: Vajad lehitsejat, mida Bootstrap 5.0 toetab, vaata <https://getbootstrap.com/docs/5.0/getting-started/browsers-devices/>.