Požadavky

Webový server

Protože je rozhraní phpMyAdmina založeno výhradně na prohlížeči, budete potřebovat webový server (například Apache, nginx, IIS), na který nainstalujete soubory phpMyAdmina.

PHP

  • You need PHP 7.2.5 or newer, with session support, the Standard PHP Library (SPL) extension, hash, ctype, and JSON support.
  • Z důvodu výkonu důrazně doporučujeme rozšíření mbstring (viz mbstring).
  • Pro podporu nahrávání souborů ZIP budete potřebovat rozšíření PHP zip.
  • K zobrazení vložených náhledů obrázků JPG („image/jpeg: inline“) se zachováním původního poměru stran potřebujete PHP knihovnu GD2.
  • Pokud používáte ověření pomocí souborů cookie (což je výchozí volba), důrazně doporučujeme rozšíření openssl.
  • Informace o podpoře indikátorů průběhu nahrávání najdete v části 2.9 Seeing an upload progress bar.
  • Pro podporu importu XML a Open Document Spreadsheet potřebujete rozšíření libxml.
  • Pro podporu reCAPTCHA na přihlašovací stránce potřebujete rozšíření openssl.
  • Pro podporu zobrazení nejnovější verze phpMyAdmina musíte v souboru php.ini povolit allow_url_open nebo mít rozšíření curl.

Databáze

phpMyAdmin podporuje databáze kompatibilní s MySQL.

  • MySQL 5.5 nebo novější
  • MariaDB 5.5 nebo novější

Webový prohlížeč

Pro přístup k phpMyAdminovi potřebujete webový prohlížeč s podporou cookies a JavaScriptu.

Potřebujete prohlížeč podporovaný frameworkem Bootstrap 4.5, viz <https://getbootstrap.com/docs/4.5/getting-started/browsers-devices/>.

Změněno ve verzi 5.2.0: Potřebujete prohlížeč podporovaný frameworkem Bootstrap 5.0, viz <https://getbootstrap.com/docs/5.0/getting-started/browsers-devices/>.