要件

ウェブサーバ

phpMyAdmin のインタフェースは完全にブラウザに基づいているため、 phpMyAdmin のファイルをインストールするにはウェブサーバ (Apache、 nginx、 IIS など) が必要です。

PHP

  • PHP 7.2.5 以降と session サポート、Standard PHP Library (SPL) 拡張モジュール、 hash、 ctype、JSON サポートが必要です。
  • mbstring 拡張機能 (mbstring を参照) を性能上の理由から強く推奨します。
  • ZIP ファイルのアップロードに対応するには、PHP の zip 拡張モジュールが必要です。
  • JPEG 画像のインラインサムネイル ("image/jpeg: inline") を正しい縦横比で表示する場合は、 PHP が GD2 に対応している必要があります。
  • クッキー認証を使用する場合は (既定)、 openssl 拡張モジュールを強く推奨します。
  • アップロードの進捗バーに対応するには、 2.9 アップロード進行状況バーが見えるようにする を参照してください。
  • XML と Open Document スプレッドシートのインポートに対応するには、 libxml 拡張モジュールが必要です。
  • ログインページで reCAPTCHA に対応するには、 openssl 拡張モジュールが必要です。
  • phpMyAdmin の最新のバージョンの表示に対応するには、 php.ini の中の allow_url_open を有効にするか、 curl 拡張モジュールを使用する必要があります。

データベース

phpMyAdmin は MySQL と互換性のあるデータベースに対応しています。

  • MySQL 5.5 以降
  • MariaDB 5.0 以降

ウェブブラウザ

phpMyAdmin にアクセスするには、クッキーと JavaScript を有効にしたウェブブラウザが必要です。

Bootstrap 4.5 が対応しているブラウザが必要です。 <https://getbootstrap.com/docs/4.5/getting-started/browsers-devices/> を参照してください。

バージョン 5.2.0 で変更: Bootstrap 5.0 に対応したブラウザが必要です。 <https://getbootstrap.com/docs/5.0/getting-started/browsers-devices/> を参照してください。